Frequently Asked Questions

The following are answers to frequently asked questions. As Mozart develops, some questions are no longer so frequently asked and we have archived their answers under nowadays less frequently asked questions. Please look there too if the answer to your question is not here.

 

 

 

Answers to Frequently Asked Questions


MIDI playback


When I play a Mozart tune, I hear nothing. What's wrong?

There are number of possibilities.

Important background:  Mozartuses MIDI synthesis for playback.  This is quite different from audio playback of CDs and various kinds of sound file.  MIDI comprises a set of instructions to a synthesiser which creates the sound.  There is no "recording" as such.  Computers can be properly configured for audio but not for MIDI.  MIDI is not used by your computer in the normal run of events, and so it is quite possible that you wouldn't know if this were the case.  

0) A new possible cause in 2007, especially if playback has suddenly stopped working, is simply that the latest version of Windows Media Player sets the MIDI volume to zero when you use it for anything.   (Our current view is that this new behaviour is a bug in the Media Player.)  The solution is to reset the volume.  See para (3) below.  It may also be worth creating a shortcut to the volume control and keeping it on your desktop.

The remainder of this topic addresses configuring your computer for MIDI.   It is written for Windows XP, but the procedure for other versions of Windows is very similar.

1)  Is the MIDI output port already in use by another program?  If so close the other program.  (Note that the MIDI port can sometimes be apparently in use if any program has been incorrectly shut down while playing a MIDI file.   In this case the MIDI port will be freed if you restart the computer.)

2) Go to Mozart's GlobalPreferences command and select the Playback tab in the dialogue.   The drop down list at the bottom indicates where Mozart's MIDI output is directed.  It can be one of

  • A hardware synthesiser
  • A software synthesiser
  • The MIDI mapper
  • An external Midi port

but the precise names depend on your computer.  Either of the first two is fine.   If it is "MIDI mapper" then the destination is the Windows default which is set in the control panel (see below).  [Note: earlier versions of Mozart do not have this drop-down selection: they always use the MIDI mapper.]   Using an external MIDI port will result in silence unless an external synthesiser is connected (and switched on!).

The MIDI mapper can be adjusted (in Windows XP) with

Start Menu/Control Panel/Sounds and Audio Devices.

Go to the Audio tab and there's a panel "MIDI music playback" in which a drop down list lets you select the default synthesiser.   It can also be set to an external port, with the silent result as above if you use "MIDI mapper" in Mozart without a synthesiser connected!

[In other versions of Windows the location of this may be slightly different, but the principle is the same.]

3) Open the Windows volume control.  In  Windows XP this is at

Start Menu/All programs/Accessories/Entertainment/Volume Control

It contains volume sliders for different source of sound - typically:  Wave files, CD-Audio, MIDI, Microphone, Line In, etc. and each has a "mute" check box.   Again the names may be different (according to Microsoft's whim) on your operating system.

The MIDI slider may not appear.  If not, go to the Volume Control's Options/Properties menu command.   It shows a list of possible sources with check boxes.  Make sure the one corresponding to MIDI is checked.   Then the slider should be present.   Turn it full up (you can adjust it later if this is too loud compared with (eg CD-playback).  Make sure its Mute checkbox is unchecked.   Close the volume control.

Your computer is now configured for MIDI and Mozart's playback should sound.

Back to top


When I try to play a Mozart tune, I get an error message
'MIDI output device: undefined external error' (or similar). What's wrong?

Mozart's play-back mechanism sends MIDI signals to a MIDI synthesiser via its MIDI-IN port. This message results when signals are sent to a non-existent port.

(This message was extremely rare until the upgrade to Windows 10 came out, since when a few people have experienced it. We believe it results from a bug in the Windows 10 upgrade procedure.)

The solution is to direct Mozart's MIDI output to a genuine port.

In Mozart 9 or later:

  • Use the preferences command
    ('Global Preferences on the View menu in Mozart 9, or 'Preferences' on the Tools menu in Mozart 10 and later.)
  • In the ensuing dialogue box, go to the MIDI ports tab.
  • Select a MIDI-OUT device from the drop-down list at the bottom right. (See below.)
  • Press OK

Important: the first item in the drop-down list will be 'MIDI Mapper'. This is a virtual port: the choice just means "Use Windows's default MIDI device.". The problem is almost certainly happening because the Windows 10 upgrade has not set up the Windows default output port correctly. Choosing another item from the list - a real device - should by-pass the problem.

Versions of Mozart earlier than Mozart 9 always send their MIDI output to the MIDI Mapper, and the above option is not available. (In earlier versions of Windows, users could define the default port in the Control Panel, but this is apparently no longer possible in recent versions of Windows.) And so, if you're using an earlier Mozart than Mozart 9 (which came out in 2006) the only options may be to wait for Microsoft to fix the bug, or upgrade to the most recent version of Mozart. There is an attractive upgrade offer.   But please do check that all is well with the evaluation copy before investing!


How do I play back just a few bars from my piece?

Select a block of music and press F2. Only the selected part will play, up to and including the last completely selected measure. If no block is selected, the whole piece plays.

Alternatively use the command which starts playing from the bar containing the insertion point. (This command is available from Mozart 5.)

Back to top


How do I play back a single part from my score?

Method 1: Select the single part as a block and press F2. (To select a single part, note that Ctrl+Home sends the caret to the start; Ctrl+Shift+End selects to the end; F9 toggles the selection between the current part and all parts.)

Method 2: Create a new window containing just one part using the Duplicate command. Play that and then close the window.

Method 3: (From Mozart 6) Put a MidiMute control character at the start of each strand you wish to be silent.  (See "mute" in the help system.)

Back to top


MIDI play-back misses the first note and/or always sounds like a piano?

This problem does not occur in versions Mozart 7 or later.   If you are using Mozart 6, then installing the latest Mozart 6 service pack will fix it.   It may be a problem in Mozart 5 specifically.

When Windows XP came out, there were some subtle differences (from earlier versions of Windows) in the way that some sound card drivers interpreted MIDI instructions.  This is the underlying cause of this problem.  Mozart 5 predated Windows XP and could not anticipate it.  (Earlier versions of Mozart didn't have the cursor which follows play-back and, because of that, don't encounter this problem.)   All subsequent versions of Mozart have been redesigned to overcome this problem.

The problem can sometimes be avoided, partially at least, by inserting a bar's rest at the start of the piece (thus separating the first note from the initialisation events), or of course by taking advantage of the upgrade offer!

[Mozart is programmed very "conservatively" and because of this there have been very few instances of problems using older versions of  Mozart on newer versions of Windows, but unfortunately this is one of them.]

Back to top


The MIDI play-back doesn't always sound right.  Why not?

There is now a page devoted to the basics of MIDI which may help with this question.

Back to top


How do I add percussion to my score?

There is now a page devoted to the basics of MIDI which may help with this question. It now also gives some details on how to produce different percussion sounds - with a table of instruments available on sound cards conforming to the General MIDI standard.

From Mozart 6 onwards there is much improved percussion support and this topic is covered in the help system

Back to top


Can I record my Mozart pieces on an audioCD?

If you have a CD-writer, then the software which comes with it will almost certainly allow you to compile an audioCD from a collection of .wav files.  These wav files can be created from Mozart's playback using various accessories supplied with Windows.  There has been a lot of interest in this and  the method of doing it is is now given on the tips page of this site.

Back to top


Music Editing


Text does not scale with the notes: Is this really WYSIWYG?

Mozart has two music fonts the raster font which is the default on the screen and the TrueType font which is the default on the printer. Mozart 3 onwards automatically switch to the TrueType font on the screen when you use the Zoom In command and switches back to raster when you Zoom Out to the smallest magnification. This is because the raster font has been designed to let you see as much music on the screen as possible at once: that is it is designed for clarity at small sizes. To achieve this it had to be made slightly (about 20%) wider proportionately than the truetype music font. When using the raster font, the display shows the whole page slightly wider in proportion with the font.

The TrueType text fonts scale proportionately with the TrueType music font, but not with the raster music font. Therefore when you view the screen with the scalable TrueType music font, you should see an entirely WYSIWYG (What You See Is What You Get) representation, but with the raster font it is only approximately so. In the latter case in particular the right hand end of text strings will not always align properly.

(NB this should not be relevant from Mozart 5 onwards where we believe we have overcome this problem.)

The recommended procedure is therefore to enter music using the default raster font if you prefer it, but when adding text it is best to switch to the TrueType music font in order to see correct text alignment.

Back to top


I can't enter high/low enough notes (enough leger lines)

Mozart has a full range of 8 octaves spanning, the range of a piano. If you want higher or lower notes than will currently fit, then, within this very broad constraint, you only have to make room for them. Do this by increasing the gap between staves using the PageFormat command. (NB it is not sufficient to increase the gap between score lines even when the score has only one stave: the stave gap still controls how far from the stave you may place a note.)

Back to top


How do I enter chords with notes of different duration?

A "chord" in (Mozart 4 onwards) is a vertical collection of notes of the same duration in a single strand (melodic line).    It may contain an arbitrary number of notes.

To have parallel notes of different durations on the same stave, they must be in different strands.    Use the ScoreLayout command to add a second (or further) strand to a stave.  When editing a piece with more than one strand on a stave it is often convenient to split the strands temporarily on to different staves (to see more clearly what you are doing) and recombine them on the same stave when you've finished.  This is done with the ScoreSeparate and ScoreCombine commands.

For more information see the topic "Techniques for editing complex scores" in the on-line help (of Mozart 4 onwards).  

Back to top


My percussion doesn't sound like percussion?

Mozart selects MIDI assignments independently of most other features.  The chances are, if this is happening, that a strand on your percussion stave is playing on a MIDI channel other than the special percussion channel (usually channel 10).  Use the View/MidiOptions command to set it to the percussion channel.  Do not set a voice.

Back to top


Mozart hangs when I use a percussion stave with few lines in use?

This has been reported on one or two computers and has been traced to a bug in the video drivers.   Such bugs can cause problems in random places in any program.  To check if it is a video driver problem reboot your computer in safe mode, or disable all acceleration features in the video driver, and repeat the operation which caused the problem.  If all is well, then a video driver problem is indicated.  Either download debugged video drivers from the video card manufacturer's web site or use your computer with a lower level of video acceleration se in the control panel.

Back to top


Help! my tool bars have disappeared!

Tool bars can be shown and hidden with the ViewToolbars command on the View menu.

If the toolbar in question is shown as being visble, but you can't see it, then you may have left it off the screen somewhere.   (It is difficult to achieve this but one good method is to switch to a higher screen resolution, run Mozart, move the toolbar to near one edge of the screen, close Mozart, go back to a lower screen resolution and...)

However, if the toolbars are lost,    there is now a solution for recovering it.    Just run mzreset.exe   (download it or run it from here) which restores the factory settings, including toolbar positions, on all versions of Mozart from Mozart 3 onwards.

Back to top


Help! Mozart will only print very small!

Mozart's print-out should be scalable over a wide range of music sizes. If this isn't happening for you, then it may be because Mozart's scalable TrueType music symbols font has failed to install correctly or has been removed.

If you look at the fonts (Control Panel -> Fonts) then you should see, according to the version of Mozart in use:

Mozart Version Font name File name
5 Mozart 5 mozart5.ttf
6 Mozart 6 mozart6_.ttf
7 Mozart 7 mozart7_.ttf

If the font has not installed correctly then download it from here and install it manually (while Mozart is not running). To download the Mozart 7 font, right click on the link in the table above and "save as". Then copy it (Ctrl+drag) to the fonts folder in the Control Panel.

Notes:

  • These fonts are copyright and licensed freely only for use with Mozart.
     
  • Each version of Mozart requires its corresponding font.

Back to top


How do I repeat from an anacrusis?

To repeat from an anacrusis (up-beat/pick-up/...) at least one extra barline often has to be introduced.  (See "extra barline" in the Mozart help system.)   The examples below show this (by highlighting the extra bars in blue for the purposes of illustration only).   The first method shows an extra bar at the repeat; but sometimes it is more convenient to add a start of repeat bar, and use 'proper' bar lines, as in the scecond method.

anacrusis

anacrusis

Back to top


Service Packs


What are Service Packs all about?

Occasionally someone reports a problem with the latest version of Mozart to us which appears to be a bug in the program.  If we can reproduce it, then we fix it, and issue the correction free of charge to everyone in the form of a Service Pack.  This is a small program which you can download  and run to make the appropriate corrections to your Mozart installation. (See the service packs page.)

To Check whether you have the latest Service Pack installed:

  • Use Mozart's Help/About Mozart command which will tell you which version is running.
    It is a number with 4 components separated by points - for example 7.0.5.0
  • The first part gives you the major version number.
    Independent service packs are issued for different major versions.  (In the above example the service pack will be found under the heading "Service Packs for Mozart 7"
  • Go to the  service packs page and thence to the page for the service pack for the appropriate version.
  • If the service pack has a higher version number - eg 7.1.2.0 in the above case - then you should download and install it.

NB Service Packs do not apply to the Evaluation Copy which is kept fairly up-to-date independently.
 

Back to top


My clefs change all by themselves - how can I stop this happening?

In MOZART 9 onwards:

There is one underlying reason why clefs can change unexpectedly.

1. In general:

Each instrument (and that includes human voices for Mozart) has its favoured clef and transposition. So a Bb clarinet for example knows it likes treble (G) clef and is written a tone higher than it sounds. Mozart has the ability to show parts at "written pitch" or at "concert pitch" (ie at the sounding pitch). At concert pitch the part has no particular preferred clef. Thus for example a Bb clarinet part which only contained its bottom few notes (written EFG, concer DEbF) might be more conveniently shown on bass clef on a concert pitch score. But if you change that to "written pitch" the proper clef will be restored automatically (as no sane clarinettist wants to read from bass clef).   The options are on the View menu.

That is just one example of a case where a clef can change as if by magic. But there are consequences of this mechanism which are less obvious.

2. Some instruments have different alternative conventions.

Take tenor voice as an example. It can be written on treble (G) clef an octave higher than it sounds or bass (F) clef at the sounding pitch.

The two options are implemented as separate instruments. This has consequences. If you just change the clef at the start of the piece, then Mozart will let you, but it also remembers the preferred clef of the 'instrument' and may change it back at inopportune moments. To change it 'permanently', go to the menu item Score/Score Layout, and on the Instrumentation tab, replace the tenor voice with one clef to the tenor voice with the other clef.

3. Just making notes

You may not have wanted to bother with instrumentation at all, but just be making notes. However from Mozart 9, instrumentation is very strongly associated with scores an parts and, internally, cannot be entirely divorced from them. There are numerous advantages of this, but the implications for clefs require care. If you want a specific clef at the start with no instrumentation, then go to the menu item Score/Score Layout, and on the Instrumentation tab, set the 'instrument' to "<Treble staff>" or "<Bass staff>" and show your notes at "written pitch".


Do I need to use all service packs or just the latest?

Just the latest.    For example Mozart Service Pack 4.0.5 will update any of versions 4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4 to 4.0.5 in one step.

So if you miss one, don't worry - just use the latest.

Note:  The free service packs work on the purchased "Virtuoso Edition" only.  If you are trying an evaluation copy, an updated evaluation copy is usually made available for download each time a service pack is issued.

Back to top


Platform support


Which Windows platforms will Mozart run on?

See platform requirements

Back to top


Are there Mozart versions for Linux, or the Apple Mac?

There are currently no "native" versions of Mozart for operating systems other than Microsoft Windows.

However,  various Mozart have been successfully run under Windows emulators under both Linux and the Apple Mac.  At time of writing our most recent information has come from Robert Charlesworth, an experienced Mozart user who has now tried it under Linux using the Windows emulator "Wine".   Robert writes:

"Not only did I get Mozart 2005 (aka 8) to run under it (with a few little dialogue text problems) but even the midi output works - ie it plays back!   This was achieved by directing Mozart to use one of my Creative Live Value's midi ports - the Wine Midi Mapper did not work. There may be a way to get even this to work, as I haven't yet installed WineTools. [A SoundFont file must first be loaded for it to work: this can be done by using sfxload as root. I haven't yet worked out how to do this with a bootscript, but I'll get there.....]   So for all those Linux aficionados, don't despair: you may be able to get Mozart to work satisfactorily :-)"

Robert is a regular contributor to the Mozart mailing list which is a good place to ask (as there are hundreds of subscribers) if you need more information about this.   (See Mozart discussion for how to join).  One thing is pretty certain: if the free Mozart evaluation copy works for you under a Windows emulator, then the full version will work just as well.

Back to top


Installation problems


Mozart's fonts have not installed correctly

Mozart itself comes with its own "Mozart classic" musical symbols font. (For example in Mozart 10 this is mozart10.ttf) From Mozart 10 the Mozart Jazz Font is available as an add-on. This package actually has two fonts: MozartJazz10.ttf is an alternative musical symbols font for jazz charts and MozartJazzText.ttf is a text font for titles etc. in a matching style.

Mozart's installers put the fonts in your Windows Fonts folder and register them as available for use.

Ocassionally, however, Windows becomes very protective of its Fonts folder and the installation fails.

If this happens, here's what to do:

1. Reboot your computer and try the installer again. Sometimes rebooting puts Windows in a better frame of mind, and this will work.

2. If that doesn't work:

  • Open Windows Explorer on your Mozart program folder. (By default this will typically be C:\Program Files\Mozart10\ or C:\Program Files (x86)\Mozart10\ for Mozart 10.)
  • Open the folder "Data" within that one.
  • In a new window, open the Windows Fonts folder. This is most easily found from Start Menu\Control Panel\Fonts
  • Copy the .ttf files (eg by dragging) from the Data folder to the Windows Fonts folder. Again, success is best assured if you do this immediately after rebooting the computer.

Back to top


Other problems


Can I recover my work after a system crash?

With the default settings, Mozart auto-saves your work to a file in the Windows Temporary Files folder at regular intervals.  If there is a system crash while Mozart is open, the auto-save file will be left there.

After restarting, to open the file:

  • Use Mozart 's File/Open command.
  • Type %temp% into the File Name field and press the Open button.
    This will show you the Windows Temporary Files folder.
  • Type *.mz into the File Name field (replacing the previous entry).
    This will show you the Mozart files in this folder.
  • The auto saved file will have a name typically of the form ~name~.mz where "name" was the name of the file you were working on.
  • Open it and, using Save As, save it in the folder of your choice under a more standard name before continuing work on it.

For further information look up "autosave" in the index of Mozart 's help system.

From time to time it is advisable to go to the temporary files folder and delete unwanted files (from Mozart and many other programs) which may accumulate there.

Back to top


Mozart crashes on one computer but not on another?

1. Service Packs: First check that the latest Service Pack is installed.  For information see Service Packs above.

2. Video Card Hardware Acceleration: If the problem persists, then it may well be due to Video Card Acceleration and easily curable.

The Video Card - the component in your computer which drives the display monitor - is designed to be able to refresh the picture on the screen very rapidly indeed.  To get the absolute maximum in speed (a benefit mainly for fast-moving games) it can by-pass various internal safety checks which most programs are required to make as a matter of course.  This can lead to severe problems for many programs (including Mozart ) in seemingly random places.   This is recognised by Video Card manufacturers, who therefore provide a way to adjust the "hardware acceleration" of the video card. 

It is characteristic of problems due to video card acceleration that they may appear on one computer but not on another, or in completely different ways on different computers.

The solution to all sorts of problems may simply be to turn down the acceleration.  

The details of how to do this may differ slightly from one video card manufacturer to another, but typically there is a slider control to do it.  Here is how to find it.  (In particular the last step may apparently be "troubleshoot" or "performance" depending on the video card).

Windows XP:

Start Menu > Control Panel > Display > Settings > Advanced > Troubleshoot

Windows 98:

Start Menu > Settings > Control Panel > Display > Settings > Advanced > Performance

Turning it down part way or all the way may cure various problems without having a noticeable effect on the performance of your computer.

3. Audio Hardware Acceleration is also a possible cause of problems, in particular if they occur on using the play-back command.   Audio Hardware Acceleration can be turned down typically at:

Windows XP:

Start Menu > Control Panel > Sounds and Audio > Volume [Speaker Settings] > Advanced > Performance

Windows 98:

Start Menu > Settings > Control Panel > Multimedia > Audio [Playback] > Advanced properties > Performance

 

 

 

home | discussion group | contact us | to top